Forums
View unanswered posts | View active topics It is currently Fri Apr 18, 2014 7:51 pm



Reply to topic  [ 7 posts ] 
 (Resolved) One Backgound + a linear gradient doesn't work 
Author Message

Joined: Fri Feb 15, 2013 5:19 am
Posts: 16
Post (Resolved) One Backgound + a linear gradient doesn't work
Hello,
when I declare that on a link, it doesn't work (it only display gradient and no the image) :x

Code:
   -pie-background: url(../images/topnav_calendar.png), linear-gradient(#494b4d 0,#5f6265 100%); /*IE*/
      behavior: url(js/PIE.php);

I'm about to change solution.


Last edited by Beutchat on Sat Feb 16, 2013 8:21 am, edited 1 time in total.



Fri Feb 15, 2013 5:23 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1430
Post Re: One Backgound + a linear gradient doesn't work
Are you accounting for the relative path issue with images in -pie-background?
http://css3pie.com/documentation/known- ... tive-paths


Fri Feb 15, 2013 10:53 am
Profile

Joined: Fri Feb 15, 2013 5:19 am
Posts: 16
Post Re: One Backgound + a linear gradient doesn't work
Yes the path is relative to the HTML document and not the CSS.


Fri Feb 15, 2013 10:56 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1430
Post Re: One Backgound + a linear gradient doesn't work
If that's the case then it should work. Do you have a URL I can look at to help diagnose?


Fri Feb 15, 2013 10:59 am
Profile

Joined: Fri Feb 15, 2013 5:19 am
Posts: 16
Post Re: One Backgound + a linear gradient doesn't work
Yes here : http://theesdesign.net/cg/topbar.html (the calendar item on :active state > line 88 on css)
Thanks for your help.


Sat Feb 16, 2013 3:57 am
Profile

Joined: Sat Aug 21, 2010 11:12 am
Posts: 223
Post Re: One Backgound + a linear gradient doesn't work
Apply the behavior already to the a element, not just :active etc..

_________________
PIE needs more community support persons! Time is money, which means you can fund PIE development by answering support questions.


Sat Feb 16, 2013 5:36 am
Profile

Joined: Fri Feb 15, 2013 5:19 am
Posts: 16
Post Re: One Backgound + a linear gradient doesn't work
Tonttu wrote:
Apply the behavior already to the a element, not just :active etc..

Super, it came from it ! (sorry if my english isn't correct). Thanks !


Sat Feb 16, 2013 8:16 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.