[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
CSS3 PIE Forums - View topic - PIE.htc doing nothing...
Forums
View unanswered posts | View active topics It is currently Sat Feb 22, 2020 10:34 pm



Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
 PIE.htc doing nothing... 
Author Message

Joined: Tue Jan 29, 2013 3:49 pm
Posts: 7
Post PIE.htc doing nothing...


Tue Jan 29, 2013 4:08 pm
Profile

Joined: Mon Jan 28, 2013 4:10 pm
Posts: 4
Post Re: PIE.htc doing nothing...


Tue Jan 29, 2013 4:31 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: PIE.htc doing nothing...
I was able to get your code to work, putting it into standards mode by making the doctype declaration the first thing in the document (the commented-out doctype lines above it put it into quirks mode.)


Tue Jan 29, 2013 7:49 pm
Profile

Joined: Tue Jan 29, 2013 3:49 pm
Posts: 7
Post Re: PIE.htc doing nothing...
OK ... I've managed to get v1 to load and display gradients (mistake was the doctype as Jason pointed out - thanks!).

v2, however, does nothing. Path to V1 is /includes/PIE1/... and path to V2 is /includes/PIE/... Does V2 not recognize the same path as V1? If I change refs to v2 files, no gradients, etc display on the page. Ref to V1 and everything displays (minus the alpha gradients which is what I really need).

Also note that the v2 PIE.htc does not seem to get initialized whether I use the relative to site root reference /includes/PIE... OR absolute path with http://sitedomain/includes/PIE...

Trying to access the htc file in both the v1 and v2 directories results in asking me to download the file (which I assume is correct).


Thu Jan 31, 2013 1:05 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: PIE.htc doing nothing...
Do you have this on a live URL where I can take a peek? It's possible that it's a bug in v2.

If you watch the http traffic, does the PIE_IEn.js file get downloaded after PIE.htc?


Thu Jan 31, 2013 4:22 pm
Profile

Joined: Tue Jan 29, 2013 3:49 pm
Posts: 7
Post Re: PIE.htc doing nothing...
I wish it was - this is on an intranet site behind the DMZ/Firewall. I'll check on the traffic and get back to you ...


Tue Feb 05, 2013 2:11 pm
Profile

Joined: Tue Jan 29, 2013 3:49 pm
Posts: 7
Post Re: PIE.htc doing nothing...
Okie ... checked the logs and found this:

[05/Feb/2013:14:12:02 -0600] "GET /includes/PIE/PIE.htc HTTP/1.1" 304 -
so far so good ... PIE.htc is getting got ...

[05/Feb/2013:14:12:03 -0600] "GET /forms/'/includes/PIE/PIE_IE678.js HTTP/1.1" 404 17017
this is where it craps out ... instead of getting /includes/PIE/PIE_IE678.js, it appends the directory where the page is located plus an apostrophe to the beginning of the 'url'.

If I change the behavior line to include the full url of PIE.htc, I find this:
[05/Feb/2013:15:37:51 -0600] "GET /includes/PIE/PIE.htc HTTP/1.1" 304 -

and the JS call is this:
[05/Feb/2013:15:37:51 -0600] "GET /forms/%22http://opswebdev.mts.mb.ca/includes/PIE%22/PIE_IE678.js HTTP/1.1" 404 17676

It seems that regardless of what is used to call PIE.htc, the script somewhere appends the actual page's location to the beginning of the JS call.

Does this help?


Tue Feb 05, 2013 3:41 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: PIE.htc doing nothing...
What happens if you remove the quotes within the behavior url()?


Tue Feb 05, 2013 7:28 pm
Profile

Joined: Tue Jan 29, 2013 3:49 pm
Posts: 7
Post Re: PIE.htc doing nothing...
Removed the quotes in the CSS file and it works on my primary site. Now I have to figure out what is making it not work on my other two (smaller) sites here (which are on a different server). Will update if I find anything.
Thanks for all the help - fantastic proggie!


Wed Feb 06, 2013 11:10 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: PIE.htc doing nothing...
There's definitely a bug in PIE.htc when quotes are present. Quotes should absolutely be allowed so I'll fix that ASAP.


Wed Feb 06, 2013 11:31 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.