Forums
View unanswered posts | View active topics It is currently Fri Aug 22, 2014 11:41 am



Reply to topic  [ 4 posts ] 
 IE8 - Shadow not displaying correctly on one div... 
Author Message

Joined: Wed Aug 29, 2012 3:47 am
Posts: 7
Post IE8 - Shadow not displaying correctly on one div...
I have some small gaps showing in the shadow around a div. It's just in IE8, IE7 seems to be ok.
Any ideas on how to rectify this?

The PIE-generated divs look like this:

Code:
<css3-container style="left: 278px; top: 80px; position: absolute; z-index: auto; direction: ltr;">
<outset-box-shadow style="POSITION: absolute; TOP: 0px; LEFT: 0px">
   <group1><?xml:namespace prefix = css3vml ns = "urn:schemas-microsoft-com:vml" />
      <css3vml:shape style="CLIP: rect(44px,506px,86px,1px); POSITION: absolute; WIDTH: 960px; HEIGHT: 36px; BEHAVIOR: url(#default#VML); TOP: 0px; LEFT: 0px" coordsize = "1920,72" coordorigin = "1,1" filled = "t" fillcolor = "black" stroked = "f" path = " m-50,14 qy14,-50 l1906,-50 qx1970,14 l1970,58 qy1906,122 l14,122 qx-50,58 x e"><css3vml:fill></css3vml:fill><css3vml:fill></css3vml:fill></css3vml:shape>
      <css3vml:shape style="CLIP: rect(44px,1010px,86px,506px); POSITION: absolute; WIDTH: 960px; HEIGHT: 36px; BEHAVIOR: url(#default#VML); TOP: 0px; LEFT: 0px" coordsize = "1920,72" coordorigin = "1,1" filled = "t" fillcolor = "black" stroked = "f" path = " m-50,14 qy14,-50 l1906,-50 qx1970,14 l1970,58 qy1906,122 l14,122 qx-50,58 x e"><css3vml:fill></css3vml:fill><css3vml:fill></css3vml:fill></css3vml:shape>
      <css3vml:shape style="CLIP: rect(1px,1010px,43px,506px); POSITION: absolute; WIDTH: 960px; HEIGHT: 36px; BEHAVIOR: url(#default#VML); TOP: 0px; LEFT: 0px" coordsize = "1920,72" coordorigin = "1,1" filled = "t" fillcolor = "black" stroked = "f" path = " m-50,14 qy14,-50 l1906,-50 qx1970,14 l1970,58 qy1906,122 l14,122 qx-50,58 x e"><css3vml:fill></css3vml:fill><css3vml:fill></css3vml:fill></css3vml:shape>
      <css3vml:shape style="CLIP: rect(1px,505px,43px,1px); POSITION: absolute; WIDTH: 960px; HEIGHT: 36px; BEHAVIOR: url(#default#VML); TOP: 0px; LEFT: 0px" coordsize = "1920,72" coordorigin = "1,1" filled = "t" fillcolor = "black" stroked = "f" path = " m-50,14 qy14,-50 l1906,-50 qx1970,14 l1970,58 qy1906,122 l14,122 qx-50,58 x e"><css3vml:fill></css3vml:fill><css3vml:fill></css3vml:fill></css3vml:shape>
   </group1>
</outset-box-shadow>

<background style="POSITION: absolute; TOP: 0px; LEFT: 0px">
   <group1>
      <?xml:namespace prefix = css3vml ns = "urn:schemas-microsoft-com:vml" />
      <css3vml:shape style="POSITION: absolute; WIDTH: 960px; HEIGHT: 36px; BEHAVIOR: url(#default#VML); TOP: 0px; LEFT: 0px" coordsize = "1920,72" coordorigin = "1,1" fillcolor = "#dbeef2" stroked = "f" path = " m0,14 qy14,0 l1906,0 qx1920,14 l1920,58 qy1906,72 l14,72 qx0,58 x e">
         <css3vml:fill></css3vml:fill>
      </css3vml:shape>
   </group1>
</background>


Attachments:
File comment: Image showing gaps in shadow
PIE Shadow.jpg [46.74 KiB]
Not downloaded yet
Wed Aug 29, 2012 6:40 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: IE8 - Shadow not displaying correctly on one div...
Sounds like this one: https://github.com/lojjic/PIE/issues/172


Wed Aug 29, 2012 1:15 pm
Profile

Joined: Wed Aug 29, 2012 3:47 am
Posts: 7
Post Re: IE8 - Shadow not displaying correctly on one div...
Yes it does look like that. If I read the Github comment correctly, it ought to be fixed? I'm using the latest version from this site though...
Should I try to manually amend the htc file and change the blur to 80px? (any hints on how exactly very gratefully received!)


Thu Aug 30, 2012 3:46 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: IE8 - Shadow not displaying correctly on one div...
That fix is only on the master branch, not in the stable 1.0 line. You'll have to wait for the first 2.0 beta unless you're brave and want to attempt compiling and using the unstable master code.

For now, all I can suggest is to decrease the blur so it is less than half of the element's height -- once the blur is larger than half the smaller dimension then it switches to the quadrant mode that has this issue.


Thu Aug 30, 2012 10:05 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.