Forums
View unanswered posts | View active topics It is currently Wed Jul 23, 2014 2:09 pm



Reply to topic  [ 3 posts ] 
 Works on start page, but not on any sub pages 
Author Message

Joined: Fri Jul 06, 2012 6:52 am
Posts: 2
Post Works on start page, but not on any sub pages
I'm working on a big website and the current task is to get the new design in place. We are using a previous website, that is similar, as base and working from there. Now, a few days into the work I realized I hadn't taken IE7 and 8 into account so I set out to fix this. I've been using border-radius and box-shadow alot, so I thought I'd implement CSS3 PIE. It works great, except for one thing... It only wants to work on one page: the start page. As you can see here: http://netdoktor.mailr.se the menu and several other elements have a border-radius and/or a box-shadow. Everything gets this from CSS (except the white menu-buttons as for ie7 and 8 I decided to use images instead). The header, the menu and the white bar just below the menu are included (along with the <head>-tag and all the css-files it calls) in a template, which is included on every single page on the entire website. So, the CSS and PIE should work everywhere, right? Wrong. It only works on this single page. Check this page for example: http://netdoktor.mailr.se/adhd/nyheter/Test-120706-Nya-regler-fr-bemanning-i-demensomsorg/
All rounded corners and shadows are gone, except for the menu-buttons which are images (although in IE8 even these seem to disappear! what the hell?), but nothing in the CSS is different as it calls the exact same CSS files and exact same markup for the menu and header! Does ANYONE have any clue as to what might cause this? My brain is having a bit of a meltdown over this.

Also, some margins here and there are off on the subpages as well in IE7 only, like the margin below the menu.

Hope you don't mind that the site is in Swedish, shouldn't be a problem I think. :)

Any and all helt is greatly appreciated!


Fri Jul 06, 2012 7:04 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: Works on start page, but not on any sub pages
You are using a relative path to PIE.htc. IE interprets this as relative to the page's URL, not relative to the stylesheet, so it resolves correctly from the root URL but not from any sub-path URLs. See http://css3pie.com/documentation/known- ... tive-paths


Fri Jul 06, 2012 9:13 am
Profile

Joined: Fri Jul 06, 2012 6:52 am
Posts: 2
Post Re: Works on start page, but not on any sub pages
Ah, thanks! You saved me a lot of headaches. :)


Fri Jul 06, 2012 9:18 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.