Forums
View unanswered posts | View active topics It is currently Fri Oct 31, 2014 7:28 am



Reply to topic  [ 5 posts ] 
 ie6(ok), ie7(ok), ie8(troublesome) 
Author Message

Joined: Mon Jun 18, 2012 11:56 pm
Posts: 3
Post ie6(ok), ie7(ok), ie8(troublesome)
Hi

nice to have this script....and good to know its ongoing improvement and adding of functionality...

my case as follow...

please launch this site in all browsers (firefox,chrome,ie9,ie10,safari,opera)....site currently under construction...

jailbreak.webege.com

i am trying to give maximum look of my site as in latest browsers to ie6,ie7,ie8.....

first time page loads fine it is after this first load the things get messy....

follow the following steps (ie8 only)(ie6,ie7 is fine)....

1. jailbreak.webege.com
2. hover over any (sitemap,contact,detail,repo icons)
3. it will delay then apply css, this is ok since first time...
4. now hover out then hover over again...
5. this time there is a shift in the css then after some time goes and displays in its proper place...

.....

i have created the contents in another HTML and called into on mouse over via load in jquery. but before the css is applied there are a few span elements created on the fly to give this exact look in ie's via java scripting in jquery...and the class name also....

can u help me with this issue....

ie6 and ie7 are fine, ie8 is throwing this strange behavior

i tried all possible solutions mentioned in your site...but am not able to get it configured...

thanks
Aqeel


Tue Jun 19, 2012 12:16 am
Profile

Joined: Mon Jun 18, 2012 11:56 pm
Posts: 3
Post Re: ie6(ok), ie7(ok), ie8(troublesome)
hi .....

was hoping for solution post....

well if none ...

might be helpful if u can provide some examples of such situation and condition....

where the content (not plain text content but some html with it) is loaded from thrid page into first page and having it applied the css3pie format (to the content with html from third page)....

and yes third page is not linked or referenced but called with java scripting so no <link> and <script> (direct linking) for third page ....


of if any better solution ...am all ears



thanks
aqeel


Wed Jun 20, 2012 9:35 am
Profile

Joined: Mon Apr 11, 2011 4:54 pm
Posts: 53
Post Re: ie6(ok), ie7(ok), ie8(troublesome)
IE8 doesn't fire events the same way that IE<=7 does. When you display an element that has been hidden, IE8 doesn't know about it. CSS3PIE tries to fix that by monitoring all the elements it's connected to, to see if they've changed since the last time it checked (about 1/4 of a second between checks), but you can see the delay there.

What you need to do to overcome this is tell PIE that you've changed the visibility of those elements by firing an event. See here for an example.


Wed Jul 04, 2012 4:20 pm
Profile

Joined: Mon Jun 18, 2012 11:56 pm
Posts: 3
Post Re: ie6(ok), ie7(ok), ie8(troublesome)
if (window.PIE) {
$(".warningsign").fireEvent("onmove");
}



$ throws error, object doesn't support this property or method...
i am using jquery method tho....please explain what is wrong....

aqeel
thanks


Fri Jul 06, 2012 1:36 am
Profile

Joined: Mon Apr 11, 2011 4:54 pm
Posts: 53
Post Re: ie6(ok), ie7(ok), ie8(troublesome)
That's because jQuery doesn't have a fireEvent() method, it's a method on elements in Internet Explorer.

Maybe try trigger("move") instead.


Fri Jul 06, 2012 1:43 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.