Forums
View unanswered posts | View active topics It is currently Wed Nov 26, 2014 9:02 am



Reply to topic  [ 5 posts ] 
 Not working in any IE version, conflict w Modernizr/HTML5? 
Author Message

Joined: Thu Apr 14, 2011 11:15 am
Posts: 2
Post Not working in any IE version, conflict w Modernizr/HTML5?
Hi all, I'm trying to get CSS3PIE working on this site:

http://www.answeb.org/

I have to use absolute paths for the behavior url since the CMS I'm using doesn't parse the .css files, but they seem to resolve correctly:

http://www.answeb.org/file/theme/answeb ... le.css?v=2

in which the behavior directive references:

http://www.answeb.org/file/theme/answeb/css/PIE.htc

Both of which resolve when loaded into the browser url bar.

Could it be a conflict with the HTML5 I've used (though it's not working on regular divs either), or the Modernizr library? I'm stumped, any ideas appreciated.

Byron


Thu Apr 14, 2011 12:16 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: Not working in any IE version, conflict w Modernizr/HTML
I assume this is the rule you're trying to use to apply the behavior:

Code:
#container #topNav article menu #accordion #sponsors footer {
    behavior: url(http://www.answeb.org/file/theme/answeb/css/PIE.htc);
}


I think you mean those selectors to be comma-separated, no? That's not going to select anything currently.


Thu Apr 14, 2011 1:56 pm
Profile

Joined: Thu Apr 14, 2011 11:15 am
Posts: 2
Post Re: Not working in any IE version, conflict w Modernizr/HTML
Oops thanks. Fixed that, but still no luck. I just recently consolidated that behavior link from the different selectors into the single block at the top, and it wasn't working the prior way either.

Going to experiment with cutting stuff out, see if that helps any.


Thu Apr 14, 2011 7:06 pm
Profile

Joined: Mon Jan 16, 2012 9:23 am
Posts: 1
Post Re: Not working in any IE version, conflict w Modernizr/HTML
Same Problem here.

My solution was to use this custom build:
http://www.modernizr.com/download/#-fon ... fixes-load

It has the same features like the standard download with only one little difference. It’s not including respond.js. A polyfill to use mediaqueries in IE.

I did a test including a »standalone« version from respond.js which is causing the same trouble. So it’s definitely respond.js which crashes CSS3PIE but I hadn’t found the time to check what part of it is responsible.

Regards, Michael


Mon Jan 16, 2012 2:36 pm
Profile

Joined: Fri Sep 14, 2012 5:33 am
Posts: 1
Post Re: Not working in any IE version, conflict w Modernizr/HTML
I had a similar problem: :css3-container elements were rendered as text in IE8 when CSS3PIE was on the same page as Modernizr 2.5.3.

Upgrading to Modernizr 2.6.1 appears to have solved this issue.


Fri Sep 14, 2012 5:38 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.