Forums
View unanswered posts | View active topics It is currently Fri Nov 28, 2014 9:36 pm



Reply to topic  [ 10 posts ] 
 IE8 background issue 
Author Message

Joined: Sat Dec 10, 2011 4:34 am
Posts: 4
Post IE8 background issue
my site url: http://sware.me

the issue:
the blocks on my site working well in the most standart webrowser either in IE7 or IE9
but when i load my site in IE8 all the blocks with border-radious and 2 image background (right and bottom) are not working.

IE8 View on some of my blocks:
http://img855.imageshack.us/img855/1293/2222sp.jpg
(not display border-radius or a background image on the sides)

Chrome / FF / IE7/9 View:
http://img694.imageshack.us/img694/2871/222iu.jpg
(display border and background well)

any help? i know this is a known issue but if anyone have a idea how to fix it in my case it is would help a lot

thanks!!


Sat Dec 10, 2011 4:44 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: IE8 background issue
See http://css3pie.com/documentation/known-issues/#z-index


Sat Dec 10, 2011 11:29 am
Profile

Joined: Sat Dec 10, 2011 4:34 am
Posts: 4
Post Re: IE8 background issue
i dont understand what i have to do


the css:
Code:
#inner-center-des
{
   margin: 4px 0px;
   float: left;
   height: 350px;
   color: #00526d;
   font-size: 12px;
   overflow: hidden;
   width: 355px;
   padding: 5px 8px 5px 0;
   border: 4px solid #e2e2e2;
   -webkit-border-radius: 13px;
   -moz-border-radius: 13px;
   border-radius: 13px;
   background: url(images/inner-news-bottom.png) repeat-x right bottom, url(images/inner-news-right.png) repeat-y right top;
   -pie-background: #ffffff, url(images/inner-news-bottom.png) repeat-x right bottom, url(images/inner-news-right.png) repeat-y right top;
   background-color: #ffffff;
   behavior: url(/wp-content/themes/sware/PIE.htc);
}


the html:
Code:
                  <div id="inner-center-des">
                     contect here
                  </div>



help? thanks!


Mon Dec 12, 2011 11:08 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: IE8 background issue
Well it's right there at that link, I'll paste it here for you:

Quote:
1. make the target element position:relative, or
2. make the ancestor element position:relative and give it a z-index.


Mon Dec 12, 2011 11:14 am
Profile

Joined: Sat Dec 10, 2011 4:34 am
Posts: 4
Post Re: IE8 background issue
thanks for the quick reply, i am not too lazy :0 it tryed it..

add to #inner-center-des, posting: relative ...
and nothing, i do something worng?

can you please exmaple this on my code?

thanks, you going a great job!


Mon Dec 12, 2011 11:50 am
Profile

Joined: Sat Aug 21, 2010 11:12 am
Posts: 223
Post Re: IE8 background issue
What about your z-index?

_________________
PIE needs more community support persons! Time is money, which means you can fund PIE development by answering support questions.


Mon Dec 12, 2011 2:04 pm
Profile

Joined: Sat Dec 10, 2011 4:34 am
Posts: 4
Post Re: IE8 background issue
also try z-index

position: relative;
z-index: 99;
or
z-index: -1;
or
z-index: 1;


nothing doesnt work..

thanks


Mon Dec 12, 2011 5:33 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: IE8 background issue
There may be a bug here, but I'm confused what you are expecting to happen with this style:

Quote:
-pie-background: #ffffff, url(images/inner-news-bottom.png) repeat-x right bottom, url(images/inner-news-right.png) repeat-y right top;


Technically this is an invalid value according to the CSS3 spec, which says that a color value can only appear in the final background layer. This may be confusing PIE's parser.


Mon Dec 12, 2011 6:59 pm
Profile

Joined: Sat Dec 28, 2013 12:29 pm
Posts: 2
Post Re: IE8 background issue
A couple of notes:
1)There are some web server that have trouble using PIE with backgrounds. I have no trouble at all with 000webhost and others, but AwardSpace.com has some issue with images being called when the parent html is not involved. I tested this by trying to go directly to an image in the address bar. First time is loads but won't reload. Probably a PHP setting.
2)I too can load colors but not images. I've had to resort to a less than optimal solution polyfill.

Another issue worth mentioning. When I tried to use border radius since the background couldn't parse, I had a black panel. I placed a parent container behind and gave it a border. Then the child container (my real container with an image background and info) was placed inside. Even though PIE is still showing a black border, it's for the parent that is behind the child container. So by adjusting padding and margin, the background shows through and the borders are rounded. Of course I was using -pie-background: url(path to image); I did try moving the image around and lots of other things including adjusting the .htaccess file. Nothing worked but the parent/child method for the panels.

Hope this helps someone else who has a restrictive host that won't open up their php for callng images. PIE is working fine on other hosts.


Sun Feb 02, 2014 8:11 am
Profile

Joined: Thu Nov 06, 2014 2:44 am
Posts: 2
Post Re: IE8 background issue
I also tried z-index, it doesn't work for me too.


Thu Nov 06, 2014 2:46 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 10 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.