Forums
View unanswered posts | View active topics It is currently Tue Sep 23, 2014 12:17 am



Reply to topic  [ 3 posts ] 
 linear gradient not exactly perpendicular 
Author Message

Joined: Mon Jul 19, 2010 6:31 pm
Posts: 8
Post linear gradient not exactly perpendicular
This is odd. I have 2 div's next to each other and sometimes it'll be both of them, sometimes it'll just be the first. But it's supposed to look like this gradient always goes all the way across. Putting it on parent has it's own issues so I faked it by putting it on both.

So, I get away with this illusion in everything but PIE. You can tell that the gradients are either not exactly linear or if they are, they are a little off vertical or horizontal.

Here it is in PIE
Attachment:
File comment: This is with PIE
gradient_ie.png [24.57 KiB]
Downloaded 312 times


Here it is in FF 3.6.3
Attachment:
File comment: This is with firefox
gradient_ff.png [23.4 KiB]
Downloaded 312 times


Here's my PIE css:
div#peepUp div.serviceLogo{
-pie-background: linear-gradient(center bottom,rgb(170,222,249) 0%,rgb(63,158,210) 100%);
position:relative;
}

Here's Moz:
div#peepUp div.serviceLogo{
background-image: -moz-linear-gradient(center bottom,rgb(170,222,249) 0%,rgb(63,158,210) 100%);
display:block;
}

Anyway, I don't know if this is something I'm doing wrong or if PIE's a degree off or something. I suppose I can always do the gradient with an image but I'm trying to save myself an http request.

Cheers,
tack


Thu Aug 12, 2010 6:20 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: linear gradient not exactly perpendicular
That is very odd indeed! I think I see what's going on in the code to cause it -- gradient angles in VML are pretty silly so I have to run a conversion from "real" angles to VML angles, and that conversion can end up with values slightly off 0/90/180/270 degrees.

I've opened ticket http://github.com/lojjic/PIE/issues/issue/64 to track this. It should be a relatively easy fix.

Thanks very much for reporting it!


Thu Aug 12, 2010 9:01 pm
Profile

Joined: Mon Jul 19, 2010 6:31 pm
Posts: 8
Post Re: linear gradient not exactly perpendicular
jason wrote:
I've opened ticket http://github.com/lojjic/PIE/issues/issue/64 to track this. It should be a relatively easy fix.

Thanks very much for reporting it!


Hey, no prob. Thanks for the yummy PIE.


Thu Aug 12, 2010 10:16 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Bing [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.