Forums
View unanswered posts | View active topics It is currently Fri Nov 21, 2014 8:57 pm



Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
 Not a single background appearing on IE8 
Author Message

Joined: Sat Nov 06, 2010 4:55 am
Posts: 12
Post Re: Not a single background appearing on IE8
Hey there,

a nice guess, but I disabled both tab systems and have the complete same results. I was so much hoping for the tabs to break it, but they're plainly not there anymore....
The problem is not the link itself, but a sub-page, i.e. if you click on a product on the link I gave you, it opens the details page and has those problems I mentioned...


Thu Nov 11, 2010 3:07 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: Not a single background appearing on IE8
Ah, I see what you're talking about now. Unfortunately I don't know off the top of my head what could be causing it. If you can come up with a minimal testcase that would be great.


Thu Nov 11, 2010 3:20 pm
Profile

Joined: Sat Nov 06, 2010 4:55 am
Posts: 12
Post Re: Not a single background appearing on IE8
What do you mean exactly with 'minimal testcase'?


Thu Nov 11, 2010 4:14 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: Not a single background appearing on IE8
I mean something like a single file or set of files that exhibit the bug, with the least amount of code possible. That removes unnecessary variables, and often while stripping away extraneous code you are able to narrow it down to a root cause. The Mozilla folks have some good guidelines: https://wiki.mozilla.org/QA/Minimal_Test_Cases


Thu Nov 11, 2010 4:44 pm
Profile

Joined: Sat Nov 06, 2010 4:55 am
Posts: 12
Post Re: Not a single background appearing on IE8
Oh well, now I know what you mean. Unfortunately I cannot strip off that much since it is a shop system that is closed to some extent & I cannot disable loading of jQuery etc. (the tabs were my work, so I was able to disable them). Drats... CSS3Pie is working fine in most other projects.

Edit: whatever it is, it is now only affecting IE8 - all elements load fine without trashing the page, but most only do active when hovering the area. Is this possible or to some extent known to happen in some special scenario?


Fri Nov 12, 2010 3:50 am
Profile

Joined: Sat Nov 06, 2010 4:55 am
Posts: 12
Post Re: Not a single background appearing on IE8
Hey there,

since I got so many problems on the project I referred to I decided to ditch PIE for this time and use something else and the good ol' fixed-sized gifs to go. Sad to say since I had begun loving PIE a lot.

Still it bugs me that PIE seems to get in trouble when applied too often or something. On another project I got similar problems as described above - misalignment of backgrounds which re-arrange when you resize the viewport, at least in IE7. It is defo PIE since deactivating it shows the stuff correct. Is anything like that known to happen (too many PIE applications = throw up errors)?


Fri Nov 19, 2010 6:30 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: Not a single background appearing on IE8
There are no known problems due to just the number of items. I've successfully tested PIE with hundreds of elements at a time, so that's not it. More likely these are issues in the timing of when PIE gets applied to things, if they shift around after the fact and IE doesn't fire the correct onresize/onmove events.

I definitely am trying to fix or work around issues like that, but as I mentioned what I really need are minimal testcases to help me narrow down root causes. Any help you can give in that regard would be great.


Fri Nov 19, 2010 11:36 pm
Profile

Joined: Sat Nov 06, 2010 4:55 am
Posts: 12
Post Re: Not a single background appearing on IE8
Well, I would assume it has several reasons why this happens. Tried to make a little test case for my new project. There are 3 forms on that site, one that is only shown via a JS toggle. If I disable the toggle, PIE displays it just fine. In that case it was the div not being shown on loading I would assume. This was not the case on the older project where I ditched PIE.

It is a bit hard for me to do test cases properly since I have no sufficient knowledge of JS and PHP and stuff. Hope this helps nonetheless.

Jason, just to make it clear: I am thankful that people like you provide us with help and support to make the (IE) internet a better place to be. I don't think you being obliged to help me out in any way or in a short period of time. You take the time you need, and when it's perfect, it's perfect ;).


Sat Nov 20, 2010 6:46 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.