Forums
View unanswered posts | View active topics It is currently Sat Apr 19, 2014 1:52 pm



Reply to topic  [ 5 posts ] 
 PIE working in IE7 but not in IE8 
Author Message

Joined: Fri Nov 11, 2011 5:36 am
Posts: 2
Post PIE working in IE7 but not in IE8
Here is the code for IE8 :

Code:
.box{
width:200px;
height: 200px;
position: absolute;
margin-left: -100px;
left:50%;top: 50%;
background-color: green;
-webkit-border-radius: 8px;
-moz-border-radius: 8px;
border-radius: 8px;
-webkit-box-shadow: #666 0 2px 3px;
-moz-box-shadow: #666 0 2px 3px;
box-shadow: #666 0 2px 3px;
background: -webkit-gradient(linear, 0 0, 0 bottom, from(#9F9), to(#393));
background: -webkit-linear-gradient(#9F9, #393);
background: -moz-linear-gradient(#9F9, #393);
background: -ms-linear-gradient(#9F9, #393);
background: -o-linear-gradient(#9F9, #393);
-pie-background: linear-gradient(#9F9, #393);
behavior: url (_css/PIE.php);
}


I am using Parallels 6 to test IE7 & IE8 (I have also tested this on a Windows machine running IE8), it works fine using PIE.php in IE7 but doing nothing in IE8.

I have tried all of the file formats within the download folder and I have triple checked my paths and they are correct.

Any help would be great,
many thanks,
Sam.

[*]Also i have previously read on the forum that changing the positioning to relative and the z-index 0 would help but hasn't changed it, I have also set up a test document focused on this issue http://www.plantify.co.uk/testpie.html


Fri Nov 11, 2011 5:48 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1430
Post Re: PIE working in IE7 but not in IE8
Quote:
behavior: url (_css/PIE.php);


Try removing the space between the url and the opening (.


Sun Nov 13, 2011 2:27 pm
Profile

Joined: Fri Nov 11, 2011 5:36 am
Posts: 2
Post Re: PIE working in IE7 but not in IE8
YOUR A FREAKING GOD!!!!!!!!!!

:D

Such a simple fix, many thanks!


Thu Nov 17, 2011 4:46 am
Profile

Joined: Sat Aug 21, 2010 11:12 am
Posts: 223
Post Re: PIE working in IE7 but not in IE8
Hey, you know what they say, God is in the detail.

_________________
PIE needs more community support persons! Time is money, which means you can fund PIE development by answering support questions.


Thu Nov 17, 2011 4:59 am
Profile

Joined: Tue Jan 03, 2012 6:20 pm
Posts: 1
Post Re: PIE working in IE7 but not in IE8
Works also for me , have found that here The fix works well! Thanks for that. :D

Very good tool , ;)


Tue Jan 03, 2012 6:36 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.