CSS3 PIE Forums
http://css3pie.com/forum/

DOCTYPE Strange Issue in IE
http://css3pie.com/forum/viewtopic.php?f=4&t=1426
Page 1 of 1

Author:  timb [ Wed Dec 14, 2011 11:50 am ]
Post subject:  DOCTYPE Strange Issue in IE

Hi,

firstly can i say thanks for a great bit of code! I am really struggling though. Please could you help

When ever I enter any DOCTYPE in the header, my rounded-border top left and top right (on IMAGE P style) vanishes. I am forced at the moment to leave a doctype out (not good for seo)

Conversely, when I add back a strict or loose doctype, the border-shadows disappear and border-rounding returns. I am completely confused.

Everything in all non-IE browsers is fine - its just IE that is giving me the grief.

My css is here:- http://www.webmastercommunity.com/css/style.css

site here: http://www.webmastercommunity.com/

Could the google custom search css I am using somehow be in conflict?? Is there a workaround?

I have triple checked everything, and simply cannot find a solution. I on the verge of fudging a solution with rounded image sprites as you get to the point of trial and error where it is not worth it any more.

Many Thanks
Tim

Author:  jason [ Wed Dec 14, 2011 12:52 pm ]
Post subject:  Re: DOCTYPE Strange Issue in IE

Seems you're running into the common z-index issue: http://css3pie.com/documentation/known-issues/#z-index

Author:  timb [ Wed Dec 14, 2011 4:38 pm ]
Post subject:  Re: DOCTYPE Strange Issue in IE

Hi Jason

thanks for getting back so soon. I am not that technical and have updated my CSS with z-index as per your troubleshooting guide.

The problem I am having now is that when I click through the site, the initial styling (which looks great) on the first page you load, is lost after you click through to the next page you visit.

The menu loses is radius and the 'related links' on the eight loses its drop shadows. Again its just IE (Chrome and firefox are fine).

It feels like a z-index problem/ CSS layering but i am not sure.

Do you think its my CSS / content or perhaps my html is up the spout?

I am not that confident in identifying CSS deign flaws.

Thanks again

Tim

Author:  jason [ Wed Dec 14, 2011 9:46 pm ]
Post subject:  Re: DOCTYPE Strange Issue in IE

When I visit your site in IE8 all the pages work properly.

I do see a JavaScript error being thrown from analytics.js however, perhaps that has something to do with the problems you're seeing.

Author:  steventnorris [ Wed Jun 20, 2012 11:00 am ]
Post subject:  Re: DOCTYPE Strange Issue in IE

Was this ever resolved? I am running into the same issue using IE7. With doctype, no go. Without doctype, all is well.

Page 1 of 1 All times are UTC - 7 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/