CSS3 PIE Forums
http://css3pie.com/forum/

IE problem - works only on home page
http://css3pie.com/forum/viewtopic.php?f=3&t=93
Page 1 of 1

Author:  screeno [ Fri Aug 06, 2010 9:30 am ]
Post subject:  IE problem - works only on home page

Pie is working great on FF and Chrome. On IE 8 it works on the home page only. (The site I'm developing only has 2 pages now)

Check out http://urbanjules.com and click on portfolio. The rounded corners and shadow are visible on the home page but are missing on the portfolio page when viewed with IE.

Author:  screeno [ Fri Aug 06, 2010 11:34 am ]
Post subject:  Re: IE problem - works only on home page

OK, I figured this out. I had to specify an absolute path to the pie.htc file. The relative path I had specified worked fine from the home page only. Giving the complete path in my css file saved the day.

Author:  saomcol [ Tue Aug 10, 2010 2:42 am ]
Post subject:  Re: IE problem - works only on home page

How did you apply the absolute path? i am experiencing the same problem here please.

Author:  GrahamA [ Tue Aug 10, 2010 3:44 am ]
Post subject:  Re: IE problem - works only on home page

To specify absolute path to root in CSS try this:
Code:
behavior: url(/PIE.htc)


Note the slash before the filename.

Hope this helps

Author:  saomcol [ Tue Aug 10, 2010 4:56 am ]
Post subject:  Re: IE problem - works only on home page

This works on the pages in the root only. Pages in other folders don't find the file.

Author:  GrahamA [ Tue Aug 10, 2010 5:03 am ]
Post subject:  Re: IE problem - works only on home page

That's puzzling. I assume you've tried doing a full refresh of the page (Ctrl+F5) - sometimes I find it's necessary to do this with pages if all I've changed is the stylesheet - the cache functionality within the browser may not spot that anything has changed.

Have you got a link to your site that I can check. I have been unable to get it to work on my development machine and it's own localhost but when I put it live it worked.

Author:  saomcol [ Tue Aug 10, 2010 7:09 am ]
Post subject:  Re: IE problem - works only on home page

GrahamA
I have really tried: Putting the style sheet in the root folder and specifying the url as you suggested but now, even the pages in the root folder cannot load the script. I cannot give you the site URL because it's on the Intranet.

Maybe, I should tell you that it is an asp.net site. Nonetheless, thanks for your concern.

Page 1 of 1 All times are UTC - 7 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/