Forums
View unanswered posts | View active topics It is currently Sat Aug 30, 2014 10:19 pm



Reply to topic  [ 6 posts ] 
 Safari and Chrome Gradient Not working 
Author Message

Joined: Sun Aug 01, 2010 8:46 pm
Posts: 3
Post Safari and Chrome Gradient Not working
Hey all.

I am having an issue with none of my gradients working....FF and IE work fine but not Safari or Chrome. The rounded corners are working fine...

Here is my CSS:

#main_nav li a {
border: 1px solid #00b5d5;
border-bottom: none;
-webkit-border-radius: 5px 5px 0 0;
-moz-border-radius: 5px 5px 0 0;
border-radius: 5px 5px 0 0;
padding: 7px 10px;
display: block;
color: #fff;
font-weight: bold;
background: #eee; /*non-CSS3 browsers will use this*/
background: -moz-linear-gradient(90deg, #0074ab, #0090c1); /*gecko*/
background: -webkit-gradient(linear, left bottom, left top, from(#0074ab) to(#0090c1)); /*webkit*/
background: linear-gradient(#0074ab, #0090c1);
-pie-background: linear-gradient(90deg, #0074ab, #0090c1); /*PIE*/
behavior: url(styles/PIE.htc);
}

Any ideas??

Thanks a million...LOVE THE PIE!

:)


Mon Aug 02, 2010 6:23 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: Safari and Chrome Gradient Not working
It's a bit off-topic for the PIE forums, but I'll give it a shot:

You're missing a comma between the from() and to():

background: -webkit-gradient(linear, left bottom, left top, from(#0074ab), to(#0090c1));


Tue Aug 03, 2010 8:32 am
Profile

Joined: Sun Aug 01, 2010 8:46 pm
Posts: 3
Post Re: Safari and Chrome Gradient Not working
Yup that was it. My mistake about the wrong forum. I copied that CSS directly from the CSS3PIE site...

Thank you for your help anyway.


Tue Aug 03, 2010 11:12 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: Safari and Chrome Gradient Not working
Oh, are you saying the missing comma is present in some code on css3pie.com? If so, can you point me to where that is so I can fix it?


Tue Aug 03, 2010 12:30 pm
Profile

Joined: Sun Aug 01, 2010 8:46 pm
Posts: 3
Post Re: Safari and Chrome Gradient Not working
Yea, it was found on your forum though...Thanks again for your help! This thing is awesome. Great job!


Tue Aug 03, 2010 9:07 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: Safari and Chrome Gradient Not working
Ah, ok. Thanks!


Wed Aug 04, 2010 6:53 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: Baidu [Spider], Yahoo [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.