Forums
View unanswered posts | View active topics It is currently Sat Jul 26, 2014 1:15 pm



Reply to topic  [ 4 posts ] 
 -pie-background doesn't work is parent has background 
Author Message

Joined: Thu Jul 29, 2010 5:54 pm
Posts: 2
Post -pie-background doesn't work is parent has background
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
   <title>CSS3PIE test with bg</title>
   <style type="text/css">
      div {
         background: white;
      }
      p {
         -pie-background: linear-gradient(270deg, green, lime);
         behavior: url(PIE.htc);
      }
   </style>

</head>
<body>
   <p>First test</p>
   <div>
      <p>Second test</p>
   </div>
</body>
</html>
In my IE8 I get gradient for first <p> only. Any idea why? How to workaround this? I use "Version 1.0beta2".


Thu Jul 29, 2010 5:56 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: -pie-background doesn't work is parent has background
See the section on z-index at the top of the Known Issues page: http://css3pie.com/documentation/known-issues/

This is by far the most frequently asked question. I'll be updating the documentation to try and make the position:relative requirement more obvious.


Thu Jul 29, 2010 7:35 pm
Profile

Joined: Thu Jul 29, 2010 5:54 pm
Posts: 2
Post Re: -pie-background doesn't work is parent has background
jason wrote:
See the section on z-index at the top of the Known Issues page: http://css3pie.com/documentation/known-issues/

This is by far the most frequently asked question. I'll be updating the documentation to try and make the position:relative requirement more obvious.
Whoops, I'm sorry! When I saw "z-index" in "known-issues" I didn't care as I didn't specify z-index anywhere in my code. Now I understand this part still applied to me. Thanks for explaining.

Maybe you should consider renaming this header to something like "Decorations not visible (z-index problem)". Maybe that way other ppl wouldn't ask same question so often.


Fri Jul 30, 2010 1:48 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: -pie-background doesn't work is parent has background
Thanks for the suggestion, I think you're right about the title not being clear enough.


Fri Jul 30, 2010 8:33 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.