Forums
View unanswered posts | View active topics It is currently Thu Dec 14, 2017 8:27 pm



Reply to topic  [ 1 post ] 
 background-position not working with a gradient? 
Author Message

Joined: Thu Apr 07, 2011 1:35 am
Posts: 1
Post background-position not working with a gradient?
I am trying to divide two columns with a separating vertical line. I am doing this by using a background image gradient on the container div and positioning it in the middle of the container, like so (note, the container is 960px wide, so 480 is the middle):

Code:
#detail_group{
   background: -moz-linear-gradient(left center , #F2F2F2 0px, #F2F2F2 2px, #FFFFFF 3px) repeat-y scroll 480px 0 transparent;
   background: -webkit-gradient(linear, left top, right top, color-stop(0px,#F2F2F2), color-stop(2px%,#F2F2F2), color-stop(3px,#FFFFFF)) repeat-y scroll 480px 0 transparent;
   background: linear-gradient(left center , #F2F2F2 0px, #F2F2F2 2px, #FFFFFF 3px) repeat-y scroll 480px 0 transparent;
   -pie-background: linear-gradient(left center , #F2F2F2 0px, #F2F2F2 2px, #FFFFFF 3px) repeat-y scroll 480px 0 transparent;
   behavior: url(../css/PIE.php);
}


This works fine in Firefox, but in IE, the gradient line is rendered on the left side of the container and I cannot figure out how to position it in the middle. any ideas?


Thu Apr 07, 2011 1:39 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.