CSS3 PIE Forums
http://css3pie.com/forum/

PIECSS not working on css3pie.com with my IE8
http://css3pie.com/forum/viewtopic.php?f=3&t=3355
Page 1 of 2

Author:  Etdashou [ Mon May 05, 2014 1:22 pm ]
Post subject:  PIECSS not working on css3pie.com with my IE8

Hello all,

I am unable to make CSSPie work with my Internet Explorer 8. If I load http://css3pie.com/, it doesn't even work with your own website...

Is it possible that I have a new version of IE not compatible with PieCSS?

I have Version: 8.0.7601.17514

Author:  jason [ Mon May 05, 2014 4:34 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

Your version was released in 2011, it's definitely not too new.

Is this on a real Windows installation? A virtual machine? Some online testing service?

I've heard a small number of users having security settings that are too strict to allow .htc files.

Author:  Etdashou [ Tue May 06, 2014 6:13 am ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

It is in my company, which have really strict security. So I suppose they may have added this recently without me knowing about it.

What are the alternatives?

Author:  Etdashou [ Tue May 06, 2014 6:20 am ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

Or are you aware of what exactly could block htc files? Like what security setting.

Author:  jason [ Tue May 06, 2014 11:44 am ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

Sorry I'm not aware of the specific security settings that would block htc behaviors.

If this is an issue for you, you might be able to use PIE.js instead of the .htc, which shouldn't have any of the security issues. http://css3pie.com/documentation/pie-js/

Author:  Etdashou [ Tue May 06, 2014 12:05 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

I tried to use the js, but it seems like there is something not working.
I tried this simple code and it doesn't works:

Code:
<html>
<head>

<style type="text/css">
.rounded {
   width: 30%;
   border: 1px solid #999;
    -webkit-border-radius: 10px;
    -moz-border-radius: 10px;
    border-radius: 10px;
}
</style>

<script type='text/javascript' src='./resources/css/piecss/PIE.js'></script>



</head>
<body>

<div class="rounded">
asdfa sdfas dfas dasf<br />
asdfa sdfas dfas dasf<br />
asdfa sdfas dfas dasf<br />
asdfa sdfas dfas dasf<br />
asdfa sdfas dfas dasf<br />
asdfa sdfas dfas dasf<br /><br />
<br />
</div>

<script>
$(function() {
    if (window.PIE) {
        $('.rounded').each(function() {
            PIE.attach(this);
        });
    }
});
</script>
</body>
</html>


Does it works on your side with IE8?

Edit: I tried with Browserstack.com and it doesn't work either.

Author:  Etdashou [ Tue May 06, 2014 12:34 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

I have asked my security guys here and it seems like we disable something called vgx.dll. If you google vgx.dll, it seems like it is recommanded to disable it as it is a big security issue.
http://threatpost.com/two-new-vulnerabi ... day/105799

We re-enabled it for test purpose and it starts working again.
We are looking at a possible patch from Microsoft to fix this.

However, if you find any bug in my Javascript code, it would really helps me, because I think it would be fine also.

Author:  jason [ Tue May 06, 2014 2:22 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

It sounds like vgx.dll is required for VML rendering, which PIE uses. If you don't have that library then PIE will not work for you.

Author:  Etdashou [ Tue May 06, 2014 5:41 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

I think this is something useful to add to your knowldge FAQ database.

Also, any idea why my Javascript doesn't work?

Author:  jason [ Wed May 07, 2014 10:19 pm ]
Post subject:  Re: PIECSS not working on css3pie.com with my IE8

Well it's not really a FAQ because it's not "frequently asked". ;) I'll consider adding it to the documentation if other users have the same problem, but so far I think you're the only one.

I'm not sure what you want me to say about your JavaScript, since we already determined it's not rendering because of the missing vgx.dll, right?

Page 1 of 2 All times are UTC - 7 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/