Forums
View unanswered posts | View active topics It is currently Thu Dec 18, 2014 11:22 am



Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
 IE, fail in Beta 3, works in previous version 
Author Message

Joined: Mon Dec 20, 2010 3:12 pm
Posts: 6
Post IE, fail in Beta 3, works in previous version
I have a couple blocks that are meant to get rounded corners - they are working fine in previous versions but the backgrounds and the rounded corners appear but then are lost in Beta 3. This looks like it would be a simple application of things not having position: relative or various z-index values, but when I swap out the current beta with a previous one, the problem goes away without changing a line of markup or style.

Has anyone else seen something like this? Any tips as to why something would work in older versions but not in the newer one?

I can't provide a live example on my dev environment, but perhaps I could share some measure of the code if needed.


Mon Dec 20, 2010 3:45 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1448
Post Re: IE, fail in Beta 3, works in previous version
If beta3 broke something then I definitely want to fix it. If you'd be able to put together a testcase that shows the problem that would be very helpful.


Mon Dec 20, 2010 5:26 pm
Profile

Joined: Mon Dec 20, 2010 3:12 pm
Posts: 6
Post Re: IE, fail in Beta 3, works in previous version
jason wrote:
If beta3 broke something then I definitely want to fix it. If you'd be able to put together a testcase that shows the problem that would be very helpful.


I will try to get you some of the code privately later today, since it is currently stored on a secured system.


Tue Dec 21, 2010 8:57 am
Profile

Joined: Mon Dec 20, 2010 3:12 pm
Posts: 6
Post Re: IE, fail in Beta 3, works in previous version
I couldn't PM you, apparently due to not having enough posts, so I tried to remove the identifying markup as best I could. Hope I didn't have to strip to much to give you the answer.

Markup:
Code:
<div class="profile_pop_wrapper">
        <dl>
            <dt>
                Profile
                <span>
                    <a id="show_profile" href="javascript:showProfile();">See all</a>
                    <a id="hide_profile" href="javascript:hideProfile();">Hide</a>
                </span>
            </dt>
            <dd class="profile_main">
                <span class="profile_pop_block">
                    <img src="/dynamic/images/avatars/0.gif" alt="blocked" title="blocked" class="avatar" />
                    <a class="PCIcon" href="#none"  id="PremierPopupDesc"><img src="/dynamic/images/account/element/account_icon_silver.png" alt="" title="" /></a>
 
                    <p class="userNameTruncLongest"><strong title="blocked">blocked</strong></p>
 
                    <span class="profile_pop_maindata">
                        <p>content removed</p>
                        <p>content removed</p>
                        <p>content removed</p>
                    </span>
                </span>
 
 
                <span class="profile_extended_left profile_pop_block">
                            <table>
                               <tr><th>Gender:</th><td><p>content removed</p></td></tr>
 
                               <tr><th>Birthday:</th><td><p>content removed</p></td></tr>
 
                               <tr><th>City:</th><td><p>None Listed
                             </p></td></tr>
 
                                <tr><th>State:</th><td><p>content removed</p></td></tr>
                                <tr><th>Country:</th><td><p>content removed</p></td></tr>
                                <tr><th>Occupation:</th><td><p>content removed</p></td></tr>
                                <tr><th>Marital Status:</th><td><p>content removed</p></td></tr>
                                <tr><th>Favorite Games:</th><td><p>
                                None<br />
                              </p></td></tr>
                            </table>
                        </span>
 
                        <span class="profile_extended_right profile_pop_block">
                            <table>
                               <tr><th>Alma Mater:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Favorite Music:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Favorite Movie:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Favorite Book:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Favorite Sport:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Favorite Sports Teams:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Hobbies:</th><td><p>content removed</p></td></tr>
 
                                <tr><th>Instant Message Name:</th><td>
                                </td></tr>
 
                                <tr><th>Instant Message Type:</th><td>
                                </td></tr>
 
                                <tr><th>Personal Description:</th><td><p>content removed</p>
                                <img src="/images/tracking/counter.gif?&loc=Profile_PlayerViewed->&u=blocked&as=4&p=whome" height="1" width="1" alt="" /></td></tr>
                            </table>
                        </span>
                </dd>
        </dl>

</div>


CSS:
Code:
.profile_pop_wrapper dd.profile_main { position: relative; padding: 10px; z-index: 2000;}
.profile_pop_block { position: relative; background: #ffffff; -webkit-border-radius: 5px; -moz-border-radius: 5px; border-radius: 5px; border: solid 1px; border-color: #aaaaaa #d4d4d4 #f0f0f0; padding: 10px; z-index: 2500; behavior: url('/dynamic/html/css/PIE.htc'); }


The CSS has been truncated considerably, I don't think I left anything out that is relevant. Hopefully it's not the quality of the markup that is causing the issue, as most of it is legacy (such as the td containing p) that was beyond the scope for me to clean up so far.

Let me know what you think, thanks!


Tue Dec 21, 2010 4:59 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1448
Post Re: IE, fail in Beta 3, works in previous version
Haven't had a chance to try your code yet, but the thing that jumps out at me is that these are span elements that contain block-level elements, which besides being invalid HTML could lead to strange display issues with or without PIE involved. If you set the spans to display:block, or if you can make them divs instead, does that help?


Tue Dec 21, 2010 5:14 pm
Profile

Joined: Mon Dec 20, 2010 3:12 pm
Posts: 6
Post Re: IE, fail in Beta 3, works in previous version
They're actually inline-block, sorry. That's declared elsewhere in the CSS:

Code:
#profile_pop dd span.profile_extended_left, #profile_pop dd span.profile_extended_right { display: inline-block; zoom: 1; *display: inline; z-index: 500; position: relative; }


You're right about it being a bit poorly coded in general - I did want to change those spans to divs when I had the chance - but I don't think that is the root cause since it was exactly the same markup and CSS with the previous beta of PIE.


Tue Dec 21, 2010 5:25 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1448
Post Re: IE, fail in Beta 3, works in previous version
Hmm... when I put your code snippet into a local HTML document and load it in IE, the rounded boxes render just fine. There must be something else at play in your full code. Any ideas what that might be?

You can email me at jason@css3pie.com if you need to send something in private.


Tue Dec 21, 2010 5:50 pm
Profile

Joined: Mon Dec 20, 2010 3:12 pm
Posts: 6
Post Re: IE, fail in Beta 3, works in previous version
Thanks, I will do that. No ideas what it might be as yet, but honestly nothing would shock me.


Tue Dec 21, 2010 6:03 pm
Profile

Joined: Thu Oct 21, 2010 7:06 am
Posts: 4
Location: Cambridge, UK
Post Re: IE, fail in Beta 3, works in previous version
I too have a rendering issue with beta 3 and have had to revert back to beta 2.

I don't have a test case at the moment, but will attempt to get one up for you to see.

***EDIT***
I hope you don't mind Jason, but I have sent you an email regarding this.

_________________
web :: blog :: twitter :: html5laboratory


Wed Dec 22, 2010 4:52 am
Profile WWW

Joined: Wed Dec 22, 2010 7:40 pm
Posts: 1
Post Re: IE, fail in Beta 3, works in previous version
I just wanted to add I had to revert to Beta 2, as well. Beta 3 was only working on some of the targeted elements, elements which work fine in Beta 2.
For example, this doesn't work in Beta 3
Code:
input.form-submit {
  background: #5382a1;
  border: 1px solid #5382a1;
  color: #fff;
  -webkit-border-radius: 3px;
  -moz-border-radius: 3px;
  border-radius: 3px;
  behavior: url("PIE.php");
}


Wed Dec 22, 2010 7:45 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.