CSS3 PIE Forums
http://css3pie.com/forum/

Can't work out what's wrong and why CSS3Pie won't kick in
http://css3pie.com/forum/viewtopic.php?f=3&t=206
Page 1 of 2

Author:  tadywankenobi [ Fri Oct 15, 2010 4:47 am ]
Post subject:  Can't work out what's wrong and why CSS3Pie won't kick in

Working on a new site and have done up a html page with a navigation using CSS3. Page can be viewed on:

http://www.tadywalsh.com/index.html

I have full remote desktop access to the server and have made sure the .htc mime type is installed. I've also change the permissions on the pie.htc file so it can be accessed. I've followed the page's http requests using Fiddler and found that it's loading the pie.htc file fine. Getting some IE "object expected" and "invalid argument" errors relating to the .htc file.

Round corners, drop shadows and background gradients aren't working and I can't work out why. Also, title of page continues to say "Connecting..."

All looks good in FF and Safari, so you can check it there to see how it should look.

I'm assuming it's something to do with my setup, so any help would be much appreciated!

Cheers,

T

Author:  jason [ Fri Oct 15, 2010 9:06 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

This is a new error I haven't seen before. PIE appears to be choking in the initialization code where it removes a temporarily-inserted element for measuring display-relative unit lengths. I don't know why it would be having a problem with this, it's a simple removeChild on something it just inserted.

Can you do me a favor and try removing the reference to IE8.js, so we can see if that's conflicting somehow?

Author:  tadywankenobi [ Wed Oct 20, 2010 8:47 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Hi Jason,

Apologies for the late reply. I'll try that later and see how it goes (don't have access at work). I'll let you know when it's gone and if it fixes it.

T

Author:  tadywankenobi [ Thu Oct 21, 2010 8:12 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Hi Jason,

I tried that to no avail. The only thing, is that the "Connecting..." that was appearing in the title of the page is now gone.

Any further ideas?

Cheers,

T

Author:  tadywankenobi [ Thu Oct 21, 2010 8:13 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

In fact, I'm sorry, the "Connecting..." is still there, my mistake.

Author:  tadywankenobi [ Thu Nov 04, 2010 8:36 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Hi Jason,

I'm still not having any joy with this. Any suggestions?

T

Author:  jason [ Thu Nov 04, 2010 10:46 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Nothing helpful for you I'm afraid. I'm going to have to dig into this deeper.

If you would be able to come up with a minimal testcase document that triggers this error, that would be extremely helpful. That's likely going to be the toughest part of this, as it appears this error only occurs in some special circumstance.

Author:  tadywankenobi [ Thu Nov 04, 2010 10:58 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Ok thanks Jason. I'll take a look at it over the weekend or something. Haven't had a lot of time to go at it. I'll strip it right back and see what happens.

T

Author:  ian [ Mon Nov 08, 2010 1:37 pm ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

The first link is missing the closing tag, so the object is not there to be found. Add the closing tag, hey presto it works!

Author:  tadywankenobi [ Tue Nov 09, 2010 4:57 am ]
Post subject:  Re: Can't work out what's wrong and why CSS3Pie won't kick i

Thanks a mill! Stupid, stupid, stupid! All sorted now.

T

Page 1 of 2 All times are UTC - 7 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/