Forums
View unanswered posts | View active topics It is currently Tue Sep 30, 2014 9:50 am



Reply to topic  [ 1 post ] 
 Changing class to 'active' doesn't update the style 
Author Message

Joined: Thu Dec 13, 2012 7:01 pm
Posts: 4
Post Changing class to 'active' doesn't update the style
Hi,

I have an HTML list similar to this:

Code:
 <ul class="switcher-list">
              <li class=" switcher-active">
                 <a id="5" class="switcher">
                   <span class="numero-tema">1</span>. <span class="titulo-tema">√Ālgebra</span>
                 </a>
             </li>
             <li class="odd">
                 <a id="6" class="switcher">
                   <span class="numero-tema">2</span>. <span class="titulo-tema">Trigonometr√≠a</span>
                 </a>
            </li>


I update the switcher-active class via jQuery when the user clicks on a link. The problem is that the css3 properties generated with css3Pie disappear (first time are shown well) when the "switcher-active" changes to another <li> element.

Anyone with the same problem knows the solution to this behaviour? Thanks.


Thu Dec 13, 2012 9:02 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: Google [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.