Forums
View unanswered posts | View active topics It is currently Tue Sep 23, 2014 8:26 pm



Reply to topic  [ 3 posts ] 
 Problem with gradient left 
Author Message

Joined: Thu Dec 13, 2012 4:22 am
Posts: 4
Post Problem with gradient left
I get problem with gradient left to right and border-left, here is the code
CSS:
Code:
.test {
   border: 1px solid #696;
   padding: 60px 0;
   text-align: center; width: 200px;
   -webkit-border-radius: 8px;
   -moz-border-radius: 8px;
   border-radius: 8px;
   -webkit-box-shadow: #666 0px 2px 3px;
   -moz-box-shadow: #666 0px 2px 3px;
   box-shadow: #666 0px 2px 3px;
   background: #EEFF99;
   background: -webkit-gradient(linear, 0 0, 0 bottom, from(#EEFF99), to(#66EE33));
   background: -webkit-linear-gradient(#EEFF99, #66EE33);
   background: -moz-linear-gradient(#EEFF99, #66EE33);
   background: -ms-linear-gradient(#EEFF99, #66EE33);
   background: -o-linear-gradient(#EEFF99, #66EE33);
   background: linear-gradient(#EEFF99, #66EE33);
   -pie-background: linear-gradient(left, #EEFF99, #66EE33);
   behavior: url(PIE.htc);
   border-left: 5px solid #E7E7E7;
   float: left;
   position:relative;
}


HTML:
Code:
<span class="test" style="width: 200px; height: 50px; display: block; float: left;">
Border Left
</span>


It works fine with:
Code:
border-right: 5px solid #E7E7E7;

but not border left


Attachments:
File comment: Wrong gradient color if only set border-left
pie.png [11.48 KiB]
Not downloaded yet
Thu Dec 13, 2012 4:29 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1441
Post Re: Problem with gradient left
That's an interesting bug, I haven't seen that one before. Would you be able to open a bug ticket in the GitHub project so I don't forget about this?


Thu Dec 13, 2012 10:25 am
Profile

Joined: Thu Dec 13, 2012 4:22 am
Posts: 4
Post Re: Problem with gradient left
I've posted a new issue here: https://github.com/lojjic/PIE/issues/253

-----

And it works if i run the html directly, for example:
C:\test.html

But does not work on:
http://localhost/test.html

-----

Hope you fix it soon as my site looks odd with this issue.
Thanks!


Thu Dec 13, 2012 7:44 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.