Forums
View unanswered posts | View active topics It is currently Thu Apr 17, 2014 9:45 am



Reply to topic  [ 2 posts ] 
 Testing border-image with IE9 
Author Message

Joined: Tue Jun 19, 2012 2:36 pm
Posts: 1
Post Testing border-image with IE9
Jason,
I've been experimenting with CSS3 PIE and am intrigued by the possibilities.
While I've manged to get the border-radius working in IE 8-9 (and, I'm assuming 6-7) I've really hit a snag with border-image in IE9.
I've noticed that there is very little mention of border-image on your discussion boards and have also noted that you have mentioned that support for this feature in IE9 is spotty.
I thought I would list for you the problems I've encountered, in hopes that it will assist you in finding a solution.

The page I've been testing is available on the web at http://desktopwebworks.com/faff/index-t ... -work.html.

I have two computers that I use for testing IE9 and, oddly, both of them have different reactions to the use of PIE.
The first machine is Windows 7 in Virtualbox.
I've had very little success in testing the page on my local network. In my HTML editing program (HTML-Kit Tools), a preview of the page will sporadically load the border and then the scrollbar will freeze. The processor will run up to 100% and stay there whether the scrollbar is moveable or not. I should add that Tools uses the installed version of IE for its preview.
Sending the page over to IE results in nearly the same behavior, except the border will appear, then disappear, then reappear. The scrollbar will freeze and unfreeze and processor runs up to 100% and stays there. Finally, a message box will appear that states something about a "long running script" and asks if I want to disable same. If the script is disabled, another error message appears stating that the page is unresponsive. Attempting to recover the page result in an error message similar to the one listed below. If the script is left enabled, the page becomes unresponsive and the scroll bar freezes.

I next attempted to test the page at the address listed above. Curiously, the page will display the border-radius, but does not display the border image, there is no space for the border image and the scrollbar scrolls up and down smoothly and with no freezes.

Next, I tried setting the behavior with the .php file online and that produced a long-running script error and the message text listed here:

Description:
A problem caused this program to stop interacting with Windows.

Problem signature:
Problem Event Name: AppHangB1
Application Name: iexplore.exe
Application Version: 9.0.8112.16421
Application Timestamp: 4d76255d
Hang Signature: eb4b
Hang Type: 131072
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Hang Signature 1: eb4b8a62140880fa2b307ee47abfaa2b
Additional Hang Signature 2: de0f
Additional Hang Signature 3: de0f2b03bd37e02356ed81be85af6164
Additional Hang Signature 4: eb4b
Additional Hang Signature 5: eb4b8a62140880fa2b307ee47abfaa2b
Additional Hang Signature 6: de0f
Additional Hang Signature 7: de0f2b03bd37e02356ed81be85af6164

I would find these different behaviors fascinating, if they weren't so annoying...LOL!

Might add that the IE9 used in the above tests has all the default settings in use for the Internet and Intranet security.

That brings us to IE9 on my laptop. This is running Windows 7 on its own partition and, as might be expected, there is different behavior with this version of IE as well.
When accessing the page over the Internet, I get the page with rounded corners and space for the border image. The scrollbar scrolls. After about 15-30 seconds, the border image appears and this freezes the scrollbar. This continues for a time and then the scrollbar unfreezes, but, on occasion, the border image will disappear and then re-appear with more freezes.
Oddly, there are no error messages and, except that the scrolling is very jerky, it seems to work fairly well.
I will admit I haven't this browser testing over my home network, but can confirm that this particular IE has none of the security settings enabled...something that may have a bearing on the different behaviors.

I also found one other message about border-image on your boards and went to his page (which is a really nice piece of work, btw) and found the same problems I've encountered.

As I said at the beginning, I'm not complaining, but just hoping that what I've found will help in your development.

If you need a beta tester for the IE9 version, do let me know, as I'm quite taken with this design I've worked up and am on a rather long deadline for completing it.

Thanks for your time.

boB


Tue Jun 19, 2012 2:39 pm
Profile

Joined: Sun Sep 16, 2012 10:54 am
Posts: 2
Post Re: Testing border-image with IE9
i would like to see my border-image on IE9 by using PIE but after the integration i can see only a white square so i think that there isn't a image-border support for IE9. isn't it?


Mon Sep 17, 2012 3:16 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot], Yahoo [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.