Forums
View unanswered posts | View active topics It is currently Sat Nov 22, 2014 11:51 am



Reply to topic  [ 4 posts ] 
 Border image on submit buttons in IE9 
Author Message

Joined: Mon Apr 30, 2012 8:59 am
Posts: 3
Post Border image on submit buttons in IE9
When I apply a border image to an input[type="submit"] element it seems to behave as if the border width is set to zero, ignoring the values set. This only happens in IE9. The same code works fine in older browsers, and when applied to other element types.


Mon Apr 30, 2012 9:06 am
Profile

Joined: Mon Apr 30, 2012 8:59 am
Posts: 3
Post Re: Border image on submit buttons in IE9
I found a workaround of adding !important to my border widths. It would appear that PIE is incorrectly resetting this property.


Tue May 01, 2012 12:04 am
Profile

Joined: Mon Apr 30, 2012 8:59 am
Posts: 3
Post Re: Border image on submit buttons in IE9
grahambates wrote:
I found a workaround of adding !important to my border widths. It would appear that PIE is incorrectly resetting this property.


This didn't work - it screwed up other IE versions. I did however find a solution by editing the source, which I've posted alongside a bug report in Github.


Tue May 01, 2012 9:53 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1446
Post Re: Border image on submit buttons in IE9
Thanks for the GitHub ticket and analysis, I will investigate this and make sure the proposed fix is safe.


Tue May 01, 2012 10:59 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.