Forums
View unanswered posts | View active topics It is currently Fri Dec 19, 2014 6:51 pm



Reply to topic  [ 2 posts ] 
 All borked in IE8 -- disappearing images, etc (no pos:fixed) 
Author Message

Joined: Thu Jul 12, 2012 4:17 am
Posts: 2
Post All borked in IE8 -- disappearing images, etc (no pos:fixed)
I'm at wit's end with this and would like a little help. See https://dl.dropbox.com/u/10925273/filme ... index.html

Site's pretty dialed in in other browsers. Even without PIE, it works ok on IE 8 (my main focus right now). Obviously no rounded corners, etc, but the menus load ok, you can see the content, etc. With PIE, it's unusable at best.

Here's a partial list of the problems:
* Dropdown (technology) doesn't show background unti you hover over Same thing with the 2nd level drop down (case studies).
* Interestingy, if you hover over case studies to get the drop down, then move back up, the dropdown (now empty) will move to left: 0 (ie, below the first level dropdown). Then, if you move back and forth along the nav bar, at some point an empty background menu will show up at body:0,0.
* The search box doesn't work. See the magnifying glass. Click to the right... that's where the search box should be.
* borders, images (ie, <img>), and background have disappeared throughout the page.

I did read the trouble shooting guide but don't have any position: fixed elements at all. I'm going to try the various fixes anyways.

Thanks for any help,
James


Thu Jul 12, 2012 4:29 am
Profile

Joined: Thu Jul 12, 2012 4:17 am
Posts: 2
Post Re: All borked in IE8 -- disappearing images, etc (no pos:fi
Well... it seems I'm not as helpless as I thought, though I still have a bit of a "FOUC" of the divs' background / border at the body's 0, 0 every time there's a formerly hidden block shown.

Despite the fact that I didn't have any position: fixed elements (though a lot of position: absolute's), that was one of the big problems. I added a few relative / z-index parents, and that fixed half my problems.

The other half were fixed with the -pie-ancestor property. Specifically, my CSS drop down menus were acting up. They use :hover, which wasn't mentioned in the examples (which focused more on the javascript updating).

Anyways... hope this helps someone... I'd like to solve the flash of body at the top left if possible.

James


Thu Jul 12, 2012 5:07 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.