[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
CSS3 PIE Forums - View topic - IE seems unable to 'GET' PIE.htc from my site
Forums
View unanswered posts | View active topics It is currently Sun Jul 05, 2020 10:33 am



Reply to topic  [ 5 posts ] 
 IE seems unable to 'GET' PIE.htc from my site 
Author Message

Joined: Thu Mar 15, 2012 11:01 am
Posts: 1
Post IE seems unable to 'GET' PIE.htc from my site
Hello, I tried searching the forum to see if anyone else had this issue and was unable to find anything, so I apologize if a similar issue existed before. I am trying to implement PIE on a Sharepoint 2010 site, and I have done this before successfully on other sites, but seem to be having difficulty with this one in particular.

At first I thought the file wasn't loading at all, it seemed as if nothing was being applied... so I double-checked the path and it was correct, and it was serving the correct content type. I opened up the developer console (F12) and started a Network capture and found this perplexing bit of data. I apologize for the formatting since it is difficult pasting tables here, hopefully the column color-coding helps:

URL Method Result Type Received Taken Initiator
/Style%20Library/PIE.htc GET 200 text/x-component 8.83 KB 125 ms N/A
/Style%20Library/PIE.htc GET (Pending...) (Pending...) 0 B (Pending...) HTML Component
/Style%20Library/PIE.htc GET (Pending...) (Pending...) 0 B (Pending...) HTML Component
/Style%20Library/PIE.htc GET (Pending...) (Pending...) 0 B (Pending...) HTML Component

So it appears like it loads initially just fine, but whenever the styles request it, it just hangs... no 404, no error... it sends the Request but receives absolutely NO Response.

Right-clicking on any of these entries and choosing "Copy URL" will in fact provide me with a valid URL that I can paste into my browser window, which will immediately begin downloading the PIE.htc file to my local hard drive. This reinforces that syntax and path should be correct, but just for the record I'm using the following:

behavior: url(/Style%20Library/PIE.htc);

Honestly, I'm not sure if this is something you can even help me with; it could be something outright odd with this particular server I'm working on... after all it's completely normal for a Sharepoint site to behave outright wacky and unstable at times. But just in case this is something you've seen before I'm crossing my fingers you might know what could be causing this behavior.

If not then I guess I'll just have to use the PIE js with some Modernizr, no biggie but the htc is always preferred of course.

Thanks for your time!


Thu Mar 15, 2012 11:32 am
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: IE seems unable to 'GET' PIE.htc from my site
I've never heard of this before, so sorry I don't have any solution for you. I'm very curious about this so please let me know if you figure out a cause.


Thu Mar 15, 2012 4:48 pm
Profile

Joined: Thu Mar 29, 2012 10:24 am
Posts: 1
Post Re: IE seems unable to 'GET' PIE.htc from my site
I was having some trouble with relative paths just now--does it work for you if you put in an absolute path? It did for me. No idea why.


Thu Mar 29, 2012 10:25 am
Profile

Joined: Thu Jul 05, 2012 4:15 pm
Posts: 2
Post Re: IE seems unable to 'GET' PIE.htc from my site


Thu Jul 05, 2012 4:19 pm
Profile

Joined: Wed Jul 14, 2010 11:46 am
Posts: 1452
Post Re: IE seems unable to 'GET' PIE.htc from my site
Thank you for the information, Robert, that is extremely helpful.


Thu Jul 05, 2012 7:05 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.