Forums
View unanswered posts | View active topics It is currently Sat Dec 16, 2017 6:59 am



Reply to topic  [ 1 post ] 
 simple mouse enter event not executing 
Author Message

Joined: Sun Nov 20, 2011 3:39 pm
Posts: 2
Post simple mouse enter event not executing
Hey all,

I'm testing a PIE set up with ie6 in ietester. Attached is a very simple case that I can't get to behave cross browser. I believe it might have to do with mouseenter events and the way I do visual modification.

For my mouseenter events, I add a new class, so a div with class bar will have class bar and bar_mouseenter during the mouse over.

The issue is, for some reason, IE6 doesn't let me mouseenter the div once pie is enabled, other IE browsers appears to work correctly. If I disable PIE the mouseenter event works fine for IE6 (i test it with just borders).

Everything important is already position relative so I'm pretty sure thats not it.

Any thoughts? Thanks in advance, and thanks for your hard work on pie.

Quick addendum - The jquery code included in my debug sample uses event delegation since thats the model that I will be using across my site. Not sure if thats important.


Attachments:
debug-sample.zip [50.59 KiB]
Downloaded 229 times
Mon Nov 21, 2011 10:27 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: Steeler [Crawler] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.